use strict;
my $str = 'Le vol est puni de la réclusion criminelle à perpétuité et de 150 000 euros d\'amende lorsqu\'il est précédé, accompagné ou suivi soit de violences ayant entraîné la mort, soit de tortures ou d\'actes de barbarie. ';
my $regex = qr/(?:(un|deux|trois|quatre|cinq|six|sept|huit|neuf|dix|quinze|vingt|trente)\s+(mois|années|année|ans|an)\s+(?:d'(emprisonnement)|de (réclusion criminelle)))|(?:de\s+la\s+(réclusion)\s+criminelle\s+à\s+(perpétuité))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}