import re
regex = re.compile(r"(?:(un|deux|trois|quatre|cinq|six|sept|huit|neuf|dix|quinze|vingt|trente)\s+(mois|années|année|ans|an)\s+(?:d'(emprisonnement)|de (réclusion criminelle)))|(?:de\s+la\s+(réclusion)\s+criminelle\s+à\s+(perpétuité))")
test_str = "Le vol est puni de la réclusion criminelle à perpétuité et de 150 000 euros d'amende lorsqu'il est précédé, accompagné ou suivi soit de violences ayant entraîné la mort, soit de tortures ou d'actes de barbarie. "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")