#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^\nA-Z]*[A-Z])(?=[^\na-z]*[a-z])(?=[^\n0-9@#&~]*[0-9@#&~])[A-Za-z0-9@#&~]{8,20}$"
Local $sString = "5abcdefG~" & @CRLF & _
"5abcdefG" & @CRLF & _
"Abc@defghi" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")