re = /^(?=[^\nA-Z]*[A-Z])(?=[^\na-z]*[a-z])(?=[^\n0-9@#&~]*[0-9@#&~])[A-Za-z0-9@#&~]{8,20}$/m
str = '5abcdefG~
5abcdefG
Abc@defghi
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end