import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^\\nA-Z]*[A-Z])(?=[^\\na-z]*[a-z])(?=[^\\n0-9@#&~]*[0-9@#&~])[A-Za-z0-9@#&~]{8,20}$";
final String string = "5abcdefG~\n"
+ "5abcdefG\n"
+ "Abc@defghi\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}