using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^\nA-Z]*[A-Z])(?=[^\na-z]*[a-z])(?=[^\n0-9@#&~]*[0-9@#&~])[A-Za-z0-9@#&~]{8,20}$";
string input = @"5abcdefG~
5abcdefG
Abc@defghi
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}