#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<=&m).*?(?=(?:\*\*|\*|__|~~)*(?:&r|$)))"
Local $sString = "plain &kobfuscated &r&lbold &r&mstrikethrough &r&nunderline &r&oitalic &r&l&mbold-strikethrough &r&lbold &mbold-strikethrough &rplain" & @CRLF & _
"" & @CRLF & _
"plain &kobfuscated &r&lbold &r&mstrikethrough &r&nunderline &r&oitalic &r&l&mbold-strikethrough &r&lbold &mbold-strikethrough &rplain" & @CRLF & _
"" & @CRLF & _
"plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&nunderline &r&oitalic &r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain" & @CRLF & _
"" & @CRLF & _
"plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&nunderline &r&o*italic *&r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain" & @CRLF & _
"" & @CRLF & _
"plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&n__underline __&r&o*italic *&r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain" & @CRLF & _
"" & @CRLF & _
"plain &kobfuscated &r&l**bold **&r&m~~strikethrough ~~&r&n__underline __&r&o*italic *&r&l**&m~~bold-strikethrough ~~**&r&l**bold &m~~bold-strikethrough ~~**&rplain" & @CRLF & _
"" & @CRLF & _
"plain obfuscated **bold **~~strikethrough ~~__underline __*italic ***~~bold-strikethrough ~~****bold ~~bold-strikethrough ~~**plain"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")