const regex = new RegExp('((?<=&m).*?(?=(?:\\*\\*|\\*|__|~~)*(?:&r|$)))', 'mg')
const str = `plain &kobfuscated &r&lbold &r&mstrikethrough &r&nunderline &r&oitalic &r&l&mbold-strikethrough &r&lbold &mbold-strikethrough &rplain
plain &kobfuscated &r&lbold &r&mstrikethrough &r&nunderline &r&oitalic &r&l&mbold-strikethrough &r&lbold &mbold-strikethrough &rplain
plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&nunderline &r&oitalic &r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain
plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&nunderline &r&o*italic *&r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain
plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&n__underline __&r&o*italic *&r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain
plain &kobfuscated &r&l**bold **&r&m~~strikethrough ~~&r&n__underline __&r&o*italic *&r&l**&m~~bold-strikethrough ~~**&r&l**bold &m~~bold-strikethrough ~~**&rplain
plain obfuscated **bold **~~strikethrough ~~__underline __*italic ***~~bold-strikethrough ~~****bold ~~bold-strikethrough ~~**plain`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}