re = /((?<=&m).*?(?=(?:\*\*|\*|__|~~)*(?:&r|$)))/m
str = 'plain &kobfuscated &r&lbold &r&mstrikethrough &r&nunderline &r&oitalic &r&l&mbold-strikethrough &r&lbold &mbold-strikethrough &rplain
plain &kobfuscated &r&lbold &r&mstrikethrough &r&nunderline &r&oitalic &r&l&mbold-strikethrough &r&lbold &mbold-strikethrough &rplain
plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&nunderline &r&oitalic &r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain
plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&nunderline &r&o*italic *&r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain
plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&n__underline __&r&o*italic *&r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain
plain &kobfuscated &r&l**bold **&r&m~~strikethrough ~~&r&n__underline __&r&o*italic *&r&l**&m~~bold-strikethrough ~~**&r&l**bold &m~~bold-strikethrough ~~**&rplain
plain obfuscated **bold **~~strikethrough ~~__underline __*italic ***~~bold-strikethrough ~~****bold ~~bold-strikethrough ~~**plain'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end