using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+success=([0-9]+)$";
string input = @"something/something-else/also-different-1200/?success=1289";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}