re = /.+success=([0-9]+)$/m
str = 'something/something-else/also-different-1200/?success=1289'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end