package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+success=([0-9]+)$`)
var str = `something/something-else/also-different-1200/?success=1289`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}