$re = '/.+success=([0-9]+)$/m';
$str = 'something/something-else/also-different-1200/?success=1289';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);