#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\S*) +(\S*) +(\S*) +(\S*) +(\S*) +(.*)$"
Local $sString = "21 abc xyz xyz 1 blablabla" & @CRLF & _
"22 abc xyz 1 bla-bla-bla" & @CRLF & _
"103 abc xyz xyz 1 " & @CRLF & _
"4000 abc xyz xyz 1 blabla bla" & @CRLF & _
"4001 abc xyz xyz 1 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")