const regex = /^(\S*) +(\S*) +(\S*) +(\S*) +(\S*) +(.*)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S*) +(\\S*) +(\\S*) +(\\S*) +(\\S*) +(.*)$', 'mg')
const str = `21 abc xyz xyz 1 blablabla
22 abc xyz 1 bla-bla-bla
103 abc xyz xyz 1
4000 abc xyz xyz 1 blabla bla
4001 abc xyz xyz 1 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}