$re = '/^(\S*) +(\S*) +(\S*) +(\S*) +(\S*) +(.*)$/m';
$str = '21 abc xyz xyz 1 blablabla
22 abc xyz 1 bla-bla-bla
103 abc xyz xyz 1
4000 abc xyz xyz 1 blabla bla
4001 abc xyz xyz 1 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);