package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S*) +(\S*) +(\S*) +(\S*) +(\S*) +(.*)$`)
var str = `21 abc xyz xyz 1 blablabla
22 abc xyz 1 bla-bla-bla
103 abc xyz xyz 1
4000 abc xyz xyz 1 blabla bla
4001 abc xyz xyz 1 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}