package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\\a+`)
var str = `Stole a pair of glasses from a student in our class, then lied about it for 4 days. He was wearing the glasses today (Friday) and stated that he got them for a late birthday present. I called his grandfather, who said he was not given glasses and does not have or wear glasses. Grandfather saw the glasses the night before and told him to turn them in today. When I talked to Braylon, he admitted that he stole the glasses from William's desk and pretended to help him look for the that afternoon.
Tyron engaged in physical altercation with another male student in the AS boys' bathroom. NEPD Case # 21-00277`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}