import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\a+";
final String string = "Stole a pair of glasses from a student in our class, then lied about it for 4 days. He was wearing the glasses today (Friday) and stated that he got them for a late birthday present. I called his grandfather, who said he was not given glasses and does not have or wear glasses. Grandfather saw the glasses the night before and told him to turn them in today. When I talked to Braylon, he admitted that he stole the glasses from William's desk and pretended to help him look for the that afternoon.\n"
+ "Tyron engaged in physical altercation with another male student in the AS boys' bathroom. NEPD Case # 21-00277";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}