import re
regex = re.compile(r"\\a+", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("Stole a pair of glasses from a student in our class, then lied about it for 4 days. He was wearing the glasses today (Friday) and stated that he got them for a late birthday present. I called his grandfather, who said he was not given glasses and does not have or wear glasses. Grandfather saw the glasses the night before and told him to turn them in today. When I talked to Braylon, he admitted that he stole the glasses from William's desk and pretended to help him look for the that afternoon.\n"
"Tyron engaged in physical altercation with another male student in the AS boys' bathroom. NEPD Case # 21-00277")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")