package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D*([\d ,]+)\s*(.*)$`)
var str = `220-224 (Even) roadname1
site of 5 to 9 (odd) roadname2
16, 19 roadname3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}