// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\D*([\d ,]+)\s*(.*)$").unwrap();
let string = "220-224 (Even) roadname1
site of 5 to 9 (odd) roadname2
16, 19 roadname3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}