const regex = new RegExp('^\\D*([\\d ,]+)\\s*(.*)$', 'gm')
const str = `220-224 (Even) roadname1
site of 5 to 9 (odd) roadname2
16, 19 roadname3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}