#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[(.*?)\]"
Local $sString = "Attacks for [1d20+3] damage." & @CRLF & _
"[genderPronoun] is [1d18] years old." & @CRLF & _
"[genderPronoun] is carrying a quiver with [1d8] arrows" & @CRLF & _
" "
Local $sSubst = "1231"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)