import re
regex = re.compile(r"\[(.*?)\]")
test_str = ("Attacks for [1d20+3] damage.\n"
"[genderPronoun] is [1d18] years old.\n"
"[genderPronoun] is carrying a quiver with [1d8] arrows\n"
" ")
subst = "1231"
result = regex.sub(subst, test_str)
if result:
print(result)