re = /\[(.*?)\]/
str = 'Attacks for [1d20+3] damage.
[genderPronoun] is [1d18] years old.
[genderPronoun] is carrying a quiver with [1d8] arrows
'
subst = '1231'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result