#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)INTERROGATION\s*(.+?)(?:\R+\d|\R*$)"
Local $sString = "1. QUESTION DE PLUSIEURS MOTS EN MAJUSCULE? réponse possible ici" & @CRLF & _
"" & @CRLF & _
"2. QUESTION DE PLUSIEURS MOTS EN MAJUSCULE SANS POINT D'INTERROGATION" & @CRLF & _
"réponse possible ici" & @CRLF & _
"" & @CRLF & _
"4. QUESTION IDENTIQUE DE PLUSIEURS MOTS EN MAJUSCULE SANS POINT D'INTERROGATION" & @CRLF & _
"" & @CRLF & _
"réponse possible ici"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")