$re = '/INTERROGATION\s*(.+?)(?:\R+\d|\R*$)/s';
$str = '1. QUESTION DE PLUSIEURS MOTS EN MAJUSCULE? réponse possible ici
2. QUESTION DE PLUSIEURS MOTS EN MAJUSCULE SANS POINT D\'INTERROGATION
réponse possible ici
4. QUESTION IDENTIQUE DE PLUSIEURS MOTS EN MAJUSCULE SANS POINT D\'INTERROGATION
réponse possible ici';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);