using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"INTERROGATION\s*(.+?)(?:\R+\d|\R*$)";
string input = @"1. QUESTION DE PLUSIEURS MOTS EN MAJUSCULE? réponse possible ici
2. QUESTION DE PLUSIEURS MOTS EN MAJUSCULE SANS POINT D'INTERROGATION
réponse possible ici
4. QUESTION IDENTIQUE DE PLUSIEURS MOTS EN MAJUSCULE SANS POINT D'INTERROGATION
réponse possible ici";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}