re = /INTERROGATION\s*(.+?)(?:\R+\d|\R*$)/
str = '1. QUESTION DE PLUSIEURS MOTS EN MAJUSCULE? réponse possible ici
2. QUESTION DE PLUSIEURS MOTS EN MAJUSCULE SANS POINT D\'INTERROGATION
réponse possible ici
4. QUESTION IDENTIQUE DE PLUSIEURS MOTS EN MAJUSCULE SANS POINT D\'INTERROGATION
réponse possible ici'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end