const regex = /(\+|\-)?((180)|(1[0-7]\d|[0]?\d\d|[0]?\d))\s*°\s*(([1-5]\d|[0]?\d)(\.\d+)?\s*\')\s*(w|W|e|E)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\+|\\-)?((180)|(1[0-7]\\d|[0]?\\d\\d|[0]?\\d))\\s*°\\s*(([1-5]\\d|[0]?\\d)(\\.\\d+)?\\s*\\\')\\s*(w|W|e|E)?', 'g')
const str = `179° 36.000'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}