re = /(\+|\-)?((180)|(1[0-7]\d|[0]?\d\d|[0]?\d))\s*°\s*(([1-5]\d|[0]?\d)(\.\d+)?\s*\')\s*(w|W|e|E)?/
str = '179° 36.000\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end