$re = '/(\+|\-)?((180)|(1[0-7]\d|[0]?\d\d|[0]?\d))\s*°\s*(([1-5]\d|[0]?\d)(\.\d+)?\s*\')\s*(w|W|e|E)?/';
$str = '179° 36.000\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);