use strict;
my $str = '179° 36.000\'';
my $regex = qr/(\+|\-)?((180)|(1[0-7]\d|[0]?\d\d|[0]?\d))\s*°\s*(([1-5]\d|[0]?\d)(\.\d+)?\s*\')\s*(w|W|e|E)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}