import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)(:|=)(.*?);";
final String string = "Pontos: 450; Linhas: 446; X mínimo: 554625; Y mínimo: 9170625; Tamanho da célula: 125m; Projecao: \"SAD69 UTM zone 23S\"; Dummy: 99999; X=UTM Este SAD69 Zona 23S; Y=UTM Norte SAD69 Zona 23S; gD_FOURIER_0=Gravidade Vertical Fourier, sem correção de terreno; gD_FOURIER_2p1=Gravidade Vertical Fourier, para correção de terreno com densidade 2.1 g cm³; GDD_FOURIER_0=Gradiente GDD Fourier, sem correção de terreno. GDD_FOURIER_2p1=Gradiente GDD Fourier, para correção de terreno com densidade 2.1 g cm³; gD_FOURIER_2p1_Conformed=Gravidade Vertical Fourier, para correção de terreno com densidade 2.1g cm³, corformado ao modelo DNSC08;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}