const regex = /(.*?)(:|=)(.*?);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)(:|=)(.*?);', 'g')
const str = `Pontos: 450; Linhas: 446; X mínimo: 554625; Y mínimo: 9170625; Tamanho da célula: 125m; Projecao: "SAD69 UTM zone 23S"; Dummy: 99999; X=UTM Este SAD69 Zona 23S; Y=UTM Norte SAD69 Zona 23S; gD_FOURIER_0=Gravidade Vertical Fourier, sem correção de terreno; gD_FOURIER_2p1=Gravidade Vertical Fourier, para correção de terreno com densidade 2.1 g cm³; GDD_FOURIER_0=Gradiente GDD Fourier, sem correção de terreno. GDD_FOURIER_2p1=Gradiente GDD Fourier, para correção de terreno com densidade 2.1 g cm³; gD_FOURIER_2p1_Conformed=Gravidade Vertical Fourier, para correção de terreno com densidade 2.1g cm³, corformado ao modelo DNSC08;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}