import re
regex = re.compile(r"(.*?)(:|=)(.*?);")
test_str = "Pontos: 450; Linhas: 446; X mínimo: 554625; Y mínimo: 9170625; Tamanho da célula: 125m; Projecao: \"SAD69 UTM zone 23S\"; Dummy: 99999; X=UTM Este SAD69 Zona 23S; Y=UTM Norte SAD69 Zona 23S; gD_FOURIER_0=Gravidade Vertical Fourier, sem correção de terreno; gD_FOURIER_2p1=Gravidade Vertical Fourier, para correção de terreno com densidade 2.1 g cm³; GDD_FOURIER_0=Gradiente GDD Fourier, sem correção de terreno. GDD_FOURIER_2p1=Gradiente GDD Fourier, para correção de terreno com densidade 2.1 g cm³; gD_FOURIER_2p1_Conformed=Gravidade Vertical Fourier, para correção de terreno com densidade 2.1g cm³, corformado ao modelo DNSC08;"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")