use strict;
my $str = 'Pontos: 450; Linhas: 446; X mínimo: 554625; Y mínimo: 9170625; Tamanho da célula: 125m; Projecao: "SAD69 UTM zone 23S"; Dummy: 99999; X=UTM Este SAD69 Zona 23S; Y=UTM Norte SAD69 Zona 23S; gD_FOURIER_0=Gravidade Vertical Fourier, sem correção de terreno; gD_FOURIER_2p1=Gravidade Vertical Fourier, para correção de terreno com densidade 2.1 g cm³; GDD_FOURIER_0=Gradiente GDD Fourier, sem correção de terreno. GDD_FOURIER_2p1=Gradiente GDD Fourier, para correção de terreno com densidade 2.1 g cm³; gD_FOURIER_2p1_Conformed=Gravidade Vertical Fourier, para correção de terreno com densidade 2.1g cm³, corformado ao modelo DNSC08;';
my $regex = qr/(.*?)(:|=)(.*?);/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}