package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(?<digits>\d{2}-\d{2}|\d{2,4}).*?$`)
var str = `ML 12+ (W166) = 12
FREELANDER II 07+ = 07
Kuga 08-12 = 08-12
CRV 2012+ = 2012
RX270/350 10+ = 10
QASHQAI 2+ =
TRIBECA 05 = 05
XC60 =`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}