import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(?<digits>\\d{2}-\\d{2}|\\d{2,4}).*?$";
final String string = "ML 12+ (W166) = 12\n"
+ "FREELANDER II 07+ = 07\n"
+ "Kuga 08-12 = 08-12\n"
+ "CRV 2012+ = 2012\n"
+ "RX270/350 10+ = 10\n"
+ "QASHQAI 2+ = \n"
+ "TRIBECA 05 = 05 \n"
+ "XC60 =";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}