re = /^.*?(?<digits>\d{2}-\d{2}|\d{2,4}).*?$/m
str = 'ML 12+ (W166) = 12
FREELANDER II 07+ = 07
Kuga 08-12 = 08-12
CRV 2012+ = 2012
RX270/350 10+ = 10
QASHQAI 2+ =
TRIBECA 05 = 05
XC60 ='
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result