#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "href=["'](https?:\/\/(?:www\.|(?!www))[^\s\.]+\.[^\s"']{2,}|(?!ftp:\/\/)[^\s]+\.[^\s'"]{2,})"
Local $sString = "Yes:" & @CRLF & _
"http://google.it" & @CRLF & _
"<a href="http://www.it.com">algo</a>" & @CRLF & _
"https://something.com" & @CRLF & _
"https://www.something.com" & @CRLF & _
"<a href="iaaaaaaaat.com">hola</a>" & @CRLF & _
"http://something.com" & @CRLF & _
"http://www.something.com" & @CRLF & _
"<a href='www.it.com'>hola</a>" & @CRLF & _
"https://something.gov" & @CRLF & _
"<a href='https://www.something.gov'>Hola</a>" & @CRLF & _
"http://something.gov" & @CRLF & _
"<a href="ftp://longurljapanese.jp">hollaaaa</a>" & @CRLF & _
"" & @CRLF & _
"<a href="it.it">hollaaaa</a>" & @CRLF & _
"http://www.something.gov" & @CRLF & _
"" & @CRLF & _
"https://something.org" & @CRLF & _
"https://www.something.org" & @CRLF & _
"http://something.org" & @CRLF & _
"http://www.something.org" & @CRLF & _
"" & @CRLF & _
"https://something.net" & @CRLF & _
"https://www.something.net" & @CRLF & _
"http://something.net" & @CRLF & _
"http://www.something.net" & @CRLF & _
"" & @CRLF & _
"https://something.edu" & @CRLF & _
"https://www.something.edu" & @CRLF & _
"http://something.edu" & @CRLF & _
"http://www.something.edu" & @CRLF & _
"" & @CRLF & _
"https://something.biz" & @CRLF & _
"https://www.something.biz" & @CRLF & _
"http://something.biz" & @CRLF & _
"http://www.something.biz" & @CRLF & _
"" & @CRLF & _
"something.biz" & @CRLF & _
"www.something.biz" & @CRLF & _
"" & @CRLF & _
"something.edu" & @CRLF & _
"www.something.edu" & @CRLF & _
"" & @CRLF & _
"something.net" & @CRLF & _
"www.something.net" & @CRLF & _
"" & @CRLF & _
"something.org" & @CRLF & _
"www.something.org" & @CRLF & _
"" & @CRLF & _
"something.gov" & @CRLF & _
"www.something.gov" & @CRLF & _
"" & @CRLF & _
"something.com" & @CRLF & _
"www.something.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"No:" & @CRLF & _
"" & @CRLF & _
"https://www.something" & @CRLF & _
"http://www.something"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")