import Foundation
let pattern = #"href=["'](https?:\/\/(?:www\.|(?!www))[^\s\.]+\.[^\s"']{2,}|(?!ftp:\/\/)[^\s]+\.[^\s'"]{2,})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Yes:
http://google.it
<a href="http://www.it.com">algo</a>
https://something.com
https://www.something.com
<a href="iaaaaaaaat.com">hola</a>
http://something.com
http://www.something.com
<a href='www.it.com'>hola</a>
https://something.gov
<a href='https://www.something.gov'>Hola</a>
http://something.gov
<a href="ftp://longurljapanese.jp">hollaaaa</a>
<a href="it.it">hollaaaa</a>
http://www.something.gov
https://something.org
https://www.something.org
http://something.org
http://www.something.org
https://something.net
https://www.something.net
http://something.net
http://www.something.net
https://something.edu
https://www.something.edu
http://something.edu
http://www.something.edu
https://something.biz
https://www.something.biz
http://something.biz
http://www.something.biz
something.biz
www.something.biz
something.edu
www.something.edu
something.net
www.something.net
something.org
www.something.org
something.gov
www.something.gov
something.com
www.something.com
No:
https://www.something
http://www.something
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)