using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=[""'](https?:\/\/(?:www\.|(?!www))[^\s\.]+\.[^\s""']{2,}|(?!ftp:\/\/)[^\s]+\.[^\s'""]{2,})";
string input = @"Yes:
http://google.it
<a href=""http://www.it.com"">algo</a>
https://something.com
https://www.something.com
<a href=""iaaaaaaaat.com"">hola</a>
http://something.com
http://www.something.com
<a href='www.it.com'>hola</a>
https://something.gov
<a href='https://www.something.gov'>Hola</a>
http://something.gov
<a href=""ftp://longurljapanese.jp"">hollaaaa</a>
<a href=""it.it"">hollaaaa</a>
http://www.something.gov
https://something.org
https://www.something.org
http://something.org
http://www.something.org
https://something.net
https://www.something.net
http://something.net
http://www.something.net
https://something.edu
https://www.something.edu
http://something.edu
http://www.something.edu
https://something.biz
https://www.something.biz
http://something.biz
http://www.something.biz
something.biz
www.something.biz
something.edu
www.something.edu
something.net
www.something.net
something.org
www.something.org
something.gov
www.something.gov
something.com
www.something.com
No:
https://www.something
http://www.something";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}