# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"href=[\"'](https?:\/\/(?:www\.|(?!www))[^\s\.]+\.[^\s\"']{2,}|(?!ftp:\/\/)[^\s]+\.[^\s'\"]{2,})"
test_str = ("Yes:\n"
"http://google.it\n"
"<a href=\"http://www.it.com\">algo</a>\n"
"https://something.com\n"
"https://www.something.com\n"
"<a href=\"iaaaaaaaat.com\">hola</a>\n"
"http://something.com\n"
"http://www.something.com\n"
"<a href='www.it.com'>hola</a>\n"
"https://something.gov\n"
"<a href='https://www.something.gov'>Hola</a>\n"
"http://something.gov\n"
"<a href=\"ftp://longurljapanese.jp\">hollaaaa</a>\n\n"
"<a href=\"it.it\">hollaaaa</a>\n"
"http://www.something.gov\n\n"
"https://something.org\n"
"https://www.something.org\n"
"http://something.org\n"
"http://www.something.org\n\n"
"https://something.net\n"
"https://www.something.net\n"
"http://something.net\n"
"http://www.something.net\n\n"
"https://something.edu\n"
"https://www.something.edu\n"
"http://something.edu\n"
"http://www.something.edu\n\n"
"https://something.biz\n"
"https://www.something.biz\n"
"http://something.biz\n"
"http://www.something.biz\n\n"
"something.biz\n"
"www.something.biz\n\n"
"something.edu\n"
"www.something.edu\n\n"
"something.net\n"
"www.something.net\n\n"
"something.org\n"
"www.something.org\n\n"
"something.gov\n"
"www.something.gov\n\n"
"something.com\n"
"www.something.com\n\n\n"
"No:\n\n"
"https://www.something\n"
"http://www.something")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.