import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bexcept\\s*\\r?\\n(?:(?!(?:except|[\\t ]+raise;)$).*\\r?\\n)*end;";
final String string = "except\n"
+ " FreeAndNil(result);\n"
+ "end;\n\n"
+ "except\n"
+ " FreeAndNil(result);\n"
+ "end;\n\n\n"
+ "except\n"
+ " FreeAndNil(result);\n"
+ " raise;\n"
+ "end;\n\n"
+ "except\n"
+ " FreeAndNil(result);\n"
+ " raise;\n"
+ "end;\n\n"
+ "except\n"
+ " FreeAndNil(result);\n"
+ "end;\n\n\n"
+ "except\n"
+ " FreeAndNil(result);\n"
+ " raise;\n"
+ "end;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}