$re = '/\bexcept\s*\r?\n(?:(?!(?:except|[\t ]+raise;)$).*\r?\n)*end;/m';
$str = 'except
FreeAndNil(result);
end;
except
FreeAndNil(result);
end;
except
FreeAndNil(result);
raise;
end;
except
FreeAndNil(result);
raise;
end;
except
FreeAndNil(result);
end;
except
FreeAndNil(result);
raise;
end;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);