const regex = /\bexcept\s*\r?\n(?:(?!(?:except|[\t ]+raise;)$).*\r?\n)*end;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bexcept\\s*\\r?\\n(?:(?!(?:except|[\\t ]+raise;)$).*\\r?\\n)*end;', 'gm')
const str = `except
FreeAndNil(result);
end;
except
FreeAndNil(result);
end;
except
FreeAndNil(result);
raise;
end;
except
FreeAndNil(result);
raise;
end;
except
FreeAndNil(result);
end;
except
FreeAndNil(result);
raise;
end;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}