re = /\bexcept\s*\r?\n(?:(?!(?:except|[\t ]+raise;)$).*\r?\n)*end;/m
str = 'except
FreeAndNil(result);
end;
except
FreeAndNil(result);
end;
except
FreeAndNil(result);
raise;
end;
except
FreeAndNil(result);
raise;
end;
except
FreeAndNil(result);
end;
except
FreeAndNil(result);
raise;
end;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end