using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w-]*)\s*:\s*([^;]*)";
string input = @" border:solid 1px; color:red; background-image: url('http://example.com/image.png')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}